Link Search Menu Expand Document

pyenv

Installation

Prerequisites

For pyenv to install python correctly you should install the Python build dependencies.

macOS

brew update
brew install pyenv
pyenv which python3
pyenv install --list | grep 3.9
  3.9.0
  3.9-dev
  3.9.1
  3.9.2
  miniconda-3.9.1
  miniconda3-3.9.1
  miniconda3-3.9-4.9.2
{
    pyenv install 3.9.2
    pyenv virtualenv 3.9.2 mysite
    pyenv local mysite

    pyenv which python3
    pyenv which pip3

    pip3 install --upgrade pip
}